В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
4ae444ka
4ae444ka
03.10.2021 15:05 •  Информатика

Напишите программу для решения следующей задачи дано целое число является ли оно четным?(C++)

Ответ:
svelt04
svelt04
26.02.2021 12:50

#include <iostream>

using namespace std;

int main(){

   int n;

   cin >> n;

   if ((n & 1) == 0)

       cout << "Четное";

   else

       cout << "Нечетное";

   return 0;

}

0,0(0 оценок)
Ответ:
lboik
lboik
26.02.2021 12:50

Код на C++:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   int n;

   cin >> n;

   cout << (n % 2 ? "Нечетное (Odd)" : "Четное (Even)") << endl;

   return 0;

}

Объяснение:

Элегантное и простое решение с использованием тернарного оператора

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?