В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Shmops1063
Shmops1063
23.11.2020 07:00 •  Информатика

Язык Паскаль. Напишите программу, которая моделирует работу следующего автомата. Автомат получает на вход трехзначное число и строит новое число следующим образом: 1) вычисляются суммы первой и второй, затем - второй и третьей цифр; 2) эти суммы записываются в порядке не возрастания. Например, для числа 639 получаем суммы: 6 + 3 = 9; 3 + 9 = 12. Результат: 129 Напишите программу, которая реализует работу данного автомата

Ответ:
David2209
David2209
28.03.2021 12:29

var N,a,b,c,s1,s2:integer;

begin

Writeln('Напишите трёхзначное число');

ReadLn(N);

a:= N div 100;

b:= N div 10 mod 10;

c:= N mod 10;

s1:= a+b;

s2:= b+c;

if s1<s2 then

write(s2,s1)

else

write(s1,s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?