В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Physic777
Physic777
24.07.2020 17:17 •  Информатика

Составить программу вычисления площади круга и длину окружности величину радиуса вводить с клавиутуры ,выход из программы при нулевом радиусе

Ответ:
Євпак
Євпак
17.06.2020 08:43

С какой точностью надо вычислить площадь и длину круга? Беру 3 знака после запятой.
S - площадь круга
C - длина окружности
R - радиус окружности
Язык програмирования: Паскаль
var
S,C,R:real;
begin
read(R);
while R>0 do
begin
S:=3.14*R*R;
c:=2*3.14* R;
writeln('S = ',S:7:3,'C = ',C:7:3)
read(R);
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?