В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
apoploi
apoploi
08.05.2021 20:37 •  Информатика

Напишите программу (на паскале) для нахождения наибольшего общего делителя для чисел 12, 24, 30, 48 и 51 с использованием процедуры​

Ответ:
mjh60661
mjh60661
24.02.2021 19:20

var a,b: integer;

function NOD(x,y: integer): integer;

begin;

  if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;

end;

begin;

  readln(a,b);

  writeln( 'НОД= ', NOD(a,b) );

end.

Объяснение:begin(в переводе с английского начало)if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y(пишем этот код)end(в переводе с английского конец)Дальше пишем как я написал
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?