В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nmpepatop1
nmpepatop1
26.08.2022 20:31 •  Информатика

Написать программу, которая суммирует n отрицательных четных чисел из вводимых с клавиатуры чисел, при вводе n=0 выход из программы.

Ответ:
аааааа333
аааааа333
17.06.2020 04:25

CLS

b:

INPUT n

IF n<0 OR INT(n)<>n THEN GOTO b

IF n=0 THEN END

DIM a(n)

FOR i = 1 TO n

a:

INPUT a(n)

IF a(n) >= 0 OR INT (a(n)/2)<>(a(n)/2) THEN GOTO a

s=s+a(n)

NEXT i

PRINT s

0,0(0 оценок)
Ответ:
НацуЛюси
НацуЛюси
17.06.2020 04:25

Program ilnur17;
uses crt;
var
  n,sum,temp: integer;
begin
  write('Введите число ');
  readln(n);
  if n<>0 then
    begin
      sum:=0;
      writeln('*** alphaues is thinking... ***');
      writeln('***          OK             ***');
      while n>=1 do
        begin
          write('Введите следующее число ');
          readln(temp);
          if (temp<0) and (temp mod 2 = 0 ) then
            sum := sum + temp;
          n:=n-1
        end;
    end
  else
    writeln('Вы ввели 0 - выход из программы');
  writeln('Cуммa отрицательных четных чисел равна ',sum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?