В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
YlankinaAnastasiya
YlankinaAnastasiya
16.07.2022 17:13 •  Информатика

Написать программу, которая выводит все числа не превышающие заданного числа N, которые делятся без остатка на все свои цифры Обязательно ИМЕННО НА PYTHON

Ответ:
stefanikolaeva
stefanikolaeva
22.02.2021 17:50

ОбъяснениеPython 3.4 (нет под рукой 3.3)

n=int(input("Введите N: "))

s=''

for i in range(-n,0):

   s=s+str(-i)+' '

print(s)

Тестовое решение:

Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32

Type "copyright", "credits" or "license()" for more information.

>>> RESTART

>>>

Введите N: 5

5 4 3 2 1:

0,0(0 оценок)
Ответ:
ученик1877
ученик1877
22.02.2021 17:50

Объяснение:

Написать программу, которая выводит все числа не превышающие заданного числа N, которые делятся без остатка на все свои цифры

Обязательно ИМЕННО НА PYTHON

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?