В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
omarckina2010
omarckina2010
16.03.2021 17:25 •  Информатика

Написать программу на pascal ( из гиа). заранее огромное . напишите программу, которая в последовательности натуральных чисел определяет максимальное число оканчивающееся на 3. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число - максимальное число, оканчивающееся на 3.

Ответ:
vipzemleduh
vipzemleduh
17.06.2020 03:27

uses crt;
var a:array[1..1000] of integer;
i,max,n:integer;
begin
clrscr;
write('n<1000, n=');
read(n);

writeln('a[i]<30000, a[i]:');
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10=3) and (a[i]>max) then max:=a[i];
end;
write('max=',max);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?