В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elenaway2002
elenaway2002
08.02.2023 21:02 •  Информатика

Составьте программу  вычисления значения функции y=x3 –x2 +16x-43 для х, меняющего в диапазоне            от 4 до -4 шагом 0,5.

2)Составьте программу, печатающую все простые числа, не превосходящие заданное число.

Ответ:
Tavvi
Tavvi
23.03.2021 20:07

python

1)

from numpy import arange # нужно установить библиотеку numpy

for x in arange(4, -4, -0.5):

   print('x =', str(x) + ' :', x * 3 - x * 2 + 16 * x - 43)

2)

number = int(input('Введите число: '))

primeNumbers = []

for i in range(1, number + 1):

   numberDividers = 0

   for z in range(1, i + 1):

       if i / z == i // z:

           numberDividers += 1

   

   if numberDividers == 2:

      primeNumbers.append(i)

if len(primeNumbers) == 0:

   print('Нет простых чисел до числа ' + str(number))

else:

   print('Простые числа:')

   for i in primeNumbers:

       print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?