В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
ibraevaira
ibraevaira
22.04.2023 19:56 •  Информатика

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку "5", на экран выводится словесная отметка "Пятерка" 2)Напишите альтернативную программу с применением оператора if для 1-ой задачи

Ответ:
Поняха74
Поняха74
21.03.2021 13:56

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

case i of  

1: writeln('Единица');  

2: writeln('Двойка');  

3: writeln('Тройка');  

4: writeln('Четверка');  

5: writeln('Пятерка');  

else writeln('Нет такой оценки');  

end;  

readln;  

end.

Альтернативная задача

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

if i = 1 then writeln('Единица')

else if i = 2 then writeln('Двойка')

else if i = 3 then writeln('Тройка')

else if i = 4 then writeln('Четверка')

else if i = 5 then writeln('Пятерка')

else writeln('Нет такой оценки');    

readln;  

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?