В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dralov574
dralov574
09.04.2023 14:13 •  Информатика

Решить на Python 3 Условие

Вводится число n. Вывести 1,2,3...n−2,n−1,n,n−1,n−2...3,2,1.

Формат входных данных

Вводится целое число n (1≤n≤231−1 ).

Формат выходных данных

Вывести последовательность, сформированную по принципу, указанному в задании.

Примечания

В Питоне печать в строку: print(что-то, end=’ ’)

входные данные
4
выходные данные
1 2 3 4 3 2 1

Ответ:
magomed200495
magomed200495
20.03.2021 20:43

n=int(input())

k=1

while k<n:

   print(k,end=' ')

   k+=1

while k!=0:

   print(k, end = ' ')

   k-=1

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?