В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Python Импортируйте numpy.

Создайте матрицу (2D-массив) случайных действительных чисел (тип с плавающей запятой) размерности (5, 7). Случайные числа должны быть от 0 до 1. Отобразите эту матрицу.

Найдите минимальное и максимальное значения матрицы и отобразите эти значения с соответствующим сообщением.

Создайте массив действительных чисел длины 5, который должен содержать минимальное значение каждой строки предыдущей матрицы: первое значение массива должно содержать минимальное значение первой строки массива, второе значение массива должно содержать минимальное значение второй строки матрицы и т. д.

Отобразите эти минимальные значения с соответствующими сообщениями.

Сделала только это пока что :
import numpy as np

random_matrix_array = np.random.uniform(0, 1, size=(5, 7))
print(random_matrix_array)

random_matrix_array.min()
print("Минимум", random_matrix_array.min())

random_matrix_array.max()
print("Максимум :", random_matrix_array.max())

Ответ:
568954
568954
14.03.2021 18:42

Сделал не через numpy, как смог:

from random import random

matrix = [[random() for j in range(5)] for i in range(7)]

print('Матрица: \n', str(matrix)[1:-1].replace('], ', '\n').replace('[', '').replace(']', '').replace(',',' '), sep='')

print('Минимальное значение =>', max(max(matrix[i]) for i in range(7)))

print('Максимальное значение =>', min(min(matrix[i]) for i in range(7)))

min_mass = []

for g in matrix:

   min_mass += [min(g)]

print('Минимальные значения каждой строки пред. матрицы =>', min_mass)

Но хотя бы работает

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?