В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mumin2013
mumin2013
18.03.2023 19:35 •  Информатика

Решить на c#, используя циклы. составить программу для вычисления и вывода n первых чисел фибоначчи. числа фибоначчи получаются с следующих рекуррентных соотношений где - целое. отследить корретность ввода исходных данных.

Ответ:
kuekkukov
kuekkukov
01.10.2020 04:47

using System;

class Program
{
public static int Fibonacci(int n)
{
int a = 0;
int b = 1;
for (int i = 0; i < n; i++)
{
int temp = a;
a = b;
b = temp + b;
}
return a;
}

static void Main()
{
Console.Write("Введите N:");
int n = Int32.Parse(Console.ReadLine());
for (int i = 0; i < n; i++)
{
Console.WriteLine(Fibonacci(i));
}
}
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?