В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Yarina0311
Yarina0311
08.10.2021 15:29 •  Информатика

4«условный оператор» написать программу: дано четырехзначное число. определить, входит ли в него цифра 6.

Ответ:
Хэйллис
Хэйллис
16.06.2020 14:49

Program spinogryz21;
var
  x, i: integer;
  yes: boolean;
begin
  yes := FALSE;
  write('Введите число Х ');
  readln(x);
  for i := 1 to 4 do
  begin
    if (x mod 10) = 6 then yes := TRUE;
    x:=x div 10;
  end;
  if yes then writeln('6 входит в число Х')
  else writeln('6 не входит в число Х');
end.

0,0(0 оценок)
Ответ:
АлинаSwons
АлинаSwons
16.06.2020 14:49

uses crt;
var a,b,c,d,ch:integer;
begin
a:=0; b:=0; c:=0; d:=0;
readln(ch);
a:=ch div 1000;
b:= (ch div 100) mod 10;
c:=(ch div 10)mod 10;
d:=ch mod 10;
if ((a =6) or ( b = 6) or (c = 6 ) or ( d = 6)) then
writeln('YES') else writeln('NO');
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?