В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
KopolbEnufaHtuy
KopolbEnufaHtuy
29.08.2022 03:30 •  Информатика

Написать программу «выделение цифр в записи числа» дано трехзначное число. определить, является ли сумма его цифр кратна 3 и 5.

Ответ:
Andriuy2003
Andriuy2003
16.06.2020 14:46

var

a,s,n:integer;

begin

repeat 

write ('A =');readln(a);

until (a>=100) and (a<=999);

n:=a; 

while n div 10 <> 0 do begin

n:=a; 

s:=s+a mod 10;

a:=a div 10;

end;

if (s mod 3 = 0) or (s mod 5 = 0) then writeln ('Yes') else writeln ('No');

readln;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?