В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
diana6k3
diana6k3
17.10.2020 20:39 •  Информатика

на С++ написать программу, которая выводит заданное число на экран, а также сумму и произведение его цифр.

Ответ:
Nikita12409
Nikita12409
10.03.2021 10:10

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "russian");

int n, a=0, b=1;

cin >> n;

while (n > 0)

{

a += n % 10;

b *= n % 10;

n = n / 10;

}

cout << "Сумма цифр равна:" << a << "\nПроизведение цифр равно:" << b;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?