В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dratyti20041605
dratyti20041605
24.11.2022 14:45 •  Информатика

напишите программу которая в последовательности чисел заканчивающуюся нулем определяет среднее арифметическое четных чисел кратных 3 и трехзначных, ПИТОН

Ответ:
mrvipdanchannep0793v
mrvipdanchannep0793v
09.03.2021 17:05

summ = 0

count = 0

while 1:

   a = int(input())

   if a == 0:

       break

   elif len(str(abs(a))) == 3 and a % 2 == 0 and a % 3 == 0:

       summ += a

       count +=1

print(summ/count)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?