В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
scorpziro
scorpziro
31.01.2023 10:03 •  Информатика

Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 выходит найти ошибку


Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 вых
Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 вых

Ответ:
shevyakova2018
shevyakova2018
08.03.2021 21:19

#include<iostream>

#include<cmath>

using namespace std;

int main()

{

int n;

cin >> n;

int p = 1;

float sum = 0;

for (float i = 1; i <=n; i++)

{

p *= i;

sum += (pow(-1, i) * (i + 1)) / (p);

}

cout << sum;

}

//вместо n ты должна была написать i

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?