В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Yan116
Yan116
06.05.2020 12:40 •  Информатика

Программа в паскале! "напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел . программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа по модулю не превышают 30000." отдал все пункты что есть! !

Ответ:
Vareniki0513
Vareniki0513
16.06.2020 11:55

uses System;
var ch,min,max,i:integer;
begin cls;

readln(ch);
min:=ch;
max:=ch;

while(ch<>0) do
begin
readln(ch);
if ((min > ch) and (ch<>0)) then min:=ch;
if max < ch then max:=ch;
inc(i);
if i > 999 then break;
end;

writeln('max = ', max);
writeln('min= ',min);
writeln('suma max + min = ',max+min);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?