В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Арти2004
Арти2004
26.09.2021 15:36 •  Информатика

нужно очень На языке Паскаль Напишите программу наименьшего общего кратного следующих четырех чисел: 36, 54, 18 и 15, используя процедуру вычисления наибольшего общего делителя двух чисел.
Если можно, то с объяснением

Ответ:
veronikkot2016
veronikkot2016
06.02.2021 14:40

// НОД(a,b)*НОК(a,b)=a*b

procedure nod(x,y: integer; var n: integer);

begin

    repeat

        if x>y then x:=x mod y

        else y:=y mod x;

    until (x=0)or(y=0);

n:=x+y;

end;

var a,b,c,d,e,n: integer;

begin

readln(a,b,c,d);

nod(a,b,n);

e:=a*b div n;

nod(c,e,n);

e:=c*e div n;

nod(d,e,n);

Writeln('НОК = ',d*e div n);

end.

Объяснение:

Пример:

36 54 18 15

НОК = 540

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?