В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tolikking05
tolikking05
06.08.2020 23:52 •  Информатика

Чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количество введённых чисел неизвестно (но не
менее двух), последовательность чисел заканчивается числом 0 (0 — признак
окончания ввода, не входит в последовательность). Количество чисел не
превышает 1000. Введённые числа не превышают 10 000.
Программа должна вывести одно число: произведение двух чисел, значения
которых в данной последовательности наименьшие.
Пример работы программы:
Входные данные
10
7
8
9
0
Выходные данные
56
РЕШИТЕ УМОЛЯЮ А ТО МНЕ ППЦ ОТ РОДИТЕЛЕЙ РЕШИТЕ

Ответ:
Дашка12156
Дашка12156
06.03.2021 18:12

n1 = 9*99

n2 = 9*99

count = 0

while 1:

   a = int(input())

 

   if count < 2 and a == 0:

           print("минимум два числа")

           count -= 1

   elif  count == 1000:

       print("чисел не может быть больше 1000")

       break

   elif a > 10000:

       print("Число не может быть больше 10.000")

       count -= 1

   elif a == 0:

       break

   elif a < n1:

       n1 = a

   elif a < n2:

       n2 = a

   count += 1

print(n1*n2)


Чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количес
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?