В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tokio3
tokio3
17.09.2020 14:27 •  Информатика

дано целое двухзначное число x составьте программу вычисления суммы и произведения цифр трезначного числа x значение x ввести с клавиатуры

Ответ:
Мусора12233334555
Мусора12233334555
04.02.2021 14:40

Вариант для числа, с любым количеством цифр:

x = abs(int(input()))

s, pr = 0, 1

while x > 0:

   s += x % 10

   pr *= x % 10

   x //= 10

print(s)

print(pr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?