В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Megatrolll228
Megatrolll228
08.05.2023 19:15 •  Информатика

Написать программу (на языке Си), которая находит все двузначные числа, для которых сумма цифр входящих в число плюс квадрат суммы этих же цифр
равна самому числу.

Ответ:
usett
usett
05.03.2021 17:14

#include <stdio.h>

#include <math.h>

int main(){

   for (int i = 10; i< 100;i++)    

       if ((pow(i%10+i/10,2) + i%10 + i/10) == i)

           printf("%d\n",i);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?