В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Helen609
Helen609
23.09.2022 12:05 •  Информатика

Написать программу паскаля, которая определяет делится ли число на 3 ,но не делятся на две.

Написать программу Паскаля ,которая определяет делится ли число на 5 ​​

Ответ:
221451
221451
02.02.2021 23:40

В строке №8 записываем операцию умножения.

В строке №10 записываем операцию деления. Ее отличие от операции «Div» в том, делить можно дробные числа и результате операции могут получаться дробные числа. Запомните, что операция деления «/» не производится над переменными целого типа integer, т.к. в результате такой операции могут получиться дробные числа, и программа выдаст ошибку.


Написать программу паскаля, которая определяет делится ли число на 3 ,но не делятся на две.Написать
0,0(0 оценок)
Ответ:
Polllina2209
Polllina2209
02.02.2021 23:40

3.

program 1;

a:integer;

Begin

write ('a= ');

readln (a);

if (a mod 3=0) then

writeln ('да делится) ;

else

writeln('не делится');

readln;

end.

5.

var n:integer;

begin

write('n=');

readln(n);

if n mod 5=0 then write('Число кратно 5')

else write('Число нужно увеличить на ',5-n mod 5)

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?