В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
fedoroff67rusZah
fedoroff67rusZah
12.01.2023 00:33 •  Информатика

Надо написать программу паскаль,которая
а)Просит ввести количество людей,затем просит ввести их массу и выводит на экран их общюю массу
б)В этой же программе надо добавить их среднюю массу.
в) В этой же программе надо чтоб программа выводила на экран информацию,могут ли люди ехать в лифте чья грузоподъёмность 300 кг
даю.

Ответ:
мистертомат
мистертомат
04.03.2021 22:55

var n, k, i:integer;

m:real;

begin

   readln(n);

   

   for i:=1 to n do

       begin

           readln(k);

           m := m + k;

       end;

   

   writeln('Общая масса: ', m);

   writeln('Средняя масса: ', m/n);

   

   if (m < 300) then

       begin

           writeln('Люди могут ехать!');

       end

   else

       writeln('Ехать нельзя!');

end.

Объяснение:

б)В этой же программе надо добавить их среднюю массу.

Не совсем понял куда добавить, поэтому вывел.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?