В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kapikyna
kapikyna
03.09.2021 02:52 •  Информатика

Python: напишите программу, которая ищет количество нетривиальных делителей заданного натурального числа.

Ответ:
Lokkinine
Lokkinine
04.03.2021 19:37

number = int(input('Введите число: '))

divisors = []

for divisor in range(2, number):

   if number % divisor == 0:

       divisors.append(divisor)

print('Кол-во нетривиальных делителей: ', len(divisors))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?