В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
danilbondarenk2
danilbondarenk2
27.05.2020 12:18 •  Информатика

( Python ) Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [0;20] и находит:

1) Отдельно сумму элементов в первой и во второй половинах массива.

2)Произведение ненулевых элементов

3) Количество отрицательных элементов массива

Ответ:
66Egor99
66Egor99
04.03.2021 17:39

from random import randint

# заполняем массив случайными числами

arr = [randint(-10,10) for i in range(20)]

print(arr)

# задание 1

print(f'Сумма элементов первой половины массива {arr[0:10]} равна {sum(arr[0:10])}')

print(f'Сумма элементов второй половины массива {arr[10:20]} равна {sum(arr[10:20])}')

# задание 2

k=1

for i in arr:

   if i!=0:

       k*=i

print(f'Произведение ненулевых элементов массива равно {k}')

# задание 3

k=0

for i in arr:

   if i<0:

       k+=1

print(f'Количество отрицательных элементов массива равно {k}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?