В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
owl2006owl
owl2006owl
28.01.2022 06:26 •  Информатика

Составить программу дан массив натуральных чисел , размерность -12 ! ) заполнение массива производить с клавиатуры 2) вывести на печать только элементы кратные 2 3)найти сумму первых пяти элементов составить программу дан массив целых чисел , размерность -12 1) заполнение массива производить случайными числами из диапозона [-10; 35] 2)вывести на печать только положительные элементы 3)найти количество отрицательных элементов составить программу известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . определить количество ткани ( метров) произведенных цехом за месяц .

Ответ:
bellatrissa21
bellatrissa21
15.06.2020 22:06

1 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
write('Write a[ ',i,' ] = ');
readln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i] mod 2=0 then writeln(a[i]);
end;
for i:=1 to 5 do
begin
sum:=a[i]+sum;
end;
write('SUMA = ');
writeln(sum);
readln;
end.


2 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
a[i]:= random(46)-10; // random(max-min+1)+min;
end;
for i:=1 to 12 do
begin
if (a[i]>0) then writeln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i]<0 then inc(sum);
end;
write('OTRIC ELEMENTOV = ');
writeln(sum);
readln;
end.

ткань ...

uses crt;
var
days,m:integer;


begin
days:= 30; //дней в месяце
m:=135; //метров сделали за день
writeln('За месяц = ',days*m, ' метров ');
readln;
end.

0,0(0 оценок)
Ответ:
shevyakova2018
shevyakova2018
15.06.2020 22:06

Задача #1

 

var a:array[1..12] of integer;

i,s:integer;

begin

s:=0;

for i:=1 to 12 do

read(a[i]);

for i:=1 to 12 do

if a[i] mod 2 = 0 then write(a[i],' ');

for i:=1 to 5 do

s:=s+a[i];

writeln(s);

end.

 

Задача #2.

var a:array[1..12] of integer;

i,s:integer;

begin

s:=0;

for i:=1 to 12 do begin

randomize;

a[i]:=random(46)-10 {функция рандом будет вызывать значения от 0 до 45, и еще -10 получится от -10 до 35}

end;

For i:=1 to 12 do begin

if a[i]>0 then write(a[i],' ');

if a[i]<0 then s:=s+1;

end;

writeln(s);

end.

Стоит учесть что он не будет учитывать 0. Например, он может выдать вам 5 положительных(напишет) и количество отрицательных - 2, И это означает что остальные 5 в массиве нули.

 

Задача #3

 

var a:integer;

begin

read(a);

write(a*30);

end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?