В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
muxtarova2007
muxtarova2007
21.09.2021 07:25 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры целое число. Напишите программу, которая позволяет вводить с клавиатуры целое число и выводит на экран 4-ю, 6-ю и 8-ю степени числа. При вычислениях используйте минимальное количество действий. (Задачу выполнять без использования циклов)

Ответ:
аленаzm
аленаzm
03.03.2021 22:56

может есть проще

Объяснение:

var

 a:integer;

 b,c,d:real;

begin

    writeln('Введите целое число');

   readln(a);

   b:=sqr(sqr(a));

   c:=b*sqr(a);

   d:=sqr(b);

  writeln(a+'^4 = ',+b);

  writeln(a+'^6 = ',+c);

  writeln(a+'^8 = ',+d);

 end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?