В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
9Аноним345
9Аноним345
17.03.2023 23:59 •  Информатика

Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиатуры.

Ответ:
Aldon15
Aldon15
03.03.2021 20:02

program a1;

Var

a,b,c,max,min:integer;

Begin

Readln(a,b,c);

if (a = b) or (a = c) or (b = c) or ((a = b) and (b = c)) then

writeln('Ошибка, числа должны быть разными');

if (a>b) and (a>c) then max:=a;

if (b>a) and (b>c) then max:=b;

if (c>a) and (c>b) then max:=c;

if (a<b) and (a<c) then min:=a;

if (b<a) and (b<c) then min:=b;

if (c<a) and (c<b) then min:=c;

Writeln('Max:', max, ' Min:', min);

write('Среднее арифметическое:',(a+b+c)/3);

end.


Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?