В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
777ppp777
777ppp777
05.02.2021 05:37 •  Информатика

Информатика Составить программу которая определяет если число кратно трём, то это увеличиваем на 1, иначе уменьшаем на 2. ​

Ответ:
inpurple
inpurple
31.01.2021 19:20

var x:integer;

begin

   readln(x);

   

   if (x mod 3=0) then

       x := x + 1

   else

       x := x - 2;

       

   writeln(x);

end.

Объяснение:

Если я верно понял задачу, то решение выше.

Вводим число, если оно кратно 3 - прибавляем 1, если нет - вычту 2.

После вывожу результат.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?