В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
панда267
панда267
06.12.2021 10:13 •  Информатика

Пользователь программы вводит с клавиатуры два целых положительных числа «а» и «b», задающих диапазон целых
чисел [а;b]. Напишите программу, выводящую в строку через
пробел все простые числа из данного диапазона.

Ответ:
konovalova701
konovalova701
02.03.2021 16:32

a = int(input())

b = int(input())

for i in range(a, b + 1):

   k = 0

   for j in range(2, i // 2 + 1):

       if i % j == 0:

           k += 1

   if k == 0:

       print(i, end=' ')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?