В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MaryOnegina
MaryOnegina
16.12.2022 05:09 •  Информатика

10. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет
на языке программирования питон

Ответ:
AlisaSerikh
AlisaSerikh
02.03.2021 15:13

mass = [int(s) for s in input().split()]

k = 0

a = 0

for i in range(len(mass)):

   if mass[i] % 8 == 0:

       a += mass[i]

       k += 1

if k == 0:

   print('NO')

else:

   print(a / k)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?