В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ученик1890
ученик1890
19.01.2020 11:26 •  Информатика

PYTON Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Ответ:
kuanyshqz
kuanyshqz
27.02.2021 22:11

Решение в лоб:

x = int(input())

lucky = x % 10

check = False

x //= 10

while x > 0:

   if x % 10 == lucky:

       check = True

       break

   else:

       lucky = x % 10

   x //= 10

if check == False:

   print("Одинаковых цифр,стоящих рядом нет!")

else:

   print("Есть одинаковые цифры, стоящие рядом!")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?