В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Снежана2018
Снежана2018
05.04.2020 22:40 •  Информатика

Написать программу на паскале, которая определяет, есть ли среди цифр натурального числа n цифра k.

Ответ:
wwwnikitafakh
wwwnikitafakh
28.01.2021 18:00

program NK;

var

K, N: integer;

begin

write('Число N: ');

readln(N);

write('Цифра К: ');

readln(K);

while (N <> 0) do

begin

if ((N mod 10) = K) then

begin

writeln('Есть');

halt;

end;

N := N div 10;

end;

writeln('Нет');

readln;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?