В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
POGBOOM
POGBOOM
10.02.2020 15:06 •  Информатика

написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число интересов, которое он хочет ввести, затем он вводит их и они добавляются в первое множество. Ту же самую операцию проводим для второго пользователя.
Результат работы программы. Программа выводит на экран множество, в котором записаны совпавшие интересы. Если совпадений нет, программа выводит строку ‘Нет общих интересов’.


написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число

Ответ:
FUKCтическая
FUKCтическая
28.01.2021 15:00

interests1 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("Введите кол-во интересов: ")))]

interests2 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("2Введите кол-во интересов: ")))]

general = []

for i in interests1:

   for ii in interests2:

       if i == ii:

           general.append(i)

if len(general) != 0:

   print(f" {len(general)} общих интереса:  {general}")

else:

   print("Нет общих интересов")


написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?