В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1234fghh
1234fghh
11.02.2021 06:23 •  Информатика

Составить программу, используя двумерный массив: Рассчитать сумму положительных нечетных элементов матрицы​
(Pascal)

Ответ:
mybrainishere11
mybrainishere11
27.02.2021 00:26

var

 a: array[,] of integer;

 m, n, i, j, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(200) - 100;

     Write(a[i, j]:4);

     if (a[i, j] > 0) and (a[i, j] mod 2 = 1) then sum := sum + a[i, j];

   end;

   WriteLn;

 end;

 WriteLn('Сумма положительных нечетных элементов матрицы равна ', sum);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?