В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mokrotynp0934y
mokrotynp0934y
14.03.2021 19:05 •  Информатика

Составить программу, используя одномерные массивы: Дан массив А (15). Сформировать новый
массив из отрицательных чисел исходного массива.​
(Pascal)

Ответ:
aliska561
aliska561
27.02.2021 01:27

var

 a, b: array[1..15] of integer;

 i, k: integer;

begin

 randomize;

 k := 1;

 WriteLn('Массив:');

 for i := 1 to 15 do

 begin

   a[i] := random(200) - 100;

   Write(a[i], ', ');

   if a[i] < 0 then

   begin

     b[k] := a[i];

     inc(k);

   end;

 end;

 WriteLn;

 WriteLn('Новый массив:');

 for i := 1 to k - 1 do Write(b[i], ', ');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?