В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Пр информатике. изучили операторы for, if ,while , repeat . составьте программу , . если на одну чашу весов посадить мальчика , который весит n - кг , а на др. чашу весов насыпать n-кг конфет , к мальчику посадить девочку , которая весит на 5 кг меньше , а конфеты гораздо тяжелее детей , сколько необходимо съесть конфет детям , чтобы чаши весов уравновесились ?

Ответ:
zska25
zska25
15.06.2020 11:35

var
 n,m,i:integer;
 begin
 write('Введие вес мальчика: ');
 readln(n);
 write('Введите массу конфет (кг): ');
 readln(m);
 i:=0;
 while n+n-5<>m do
 begin
   i:=i+1;
   m:=m-1;
 end;
 writeln('Детям необходимо сьесть ',i,' кг конфет');
 end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?