В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SuperSanii
SuperSanii
09.03.2022 05:24 •  Информатика

составить программу в Python . Дан номер месяца целое число в диапазоне 1-12 (1 январь ,2 февраль и т.д) Напишите программу Которая выводит название соответствующего времени года (Зима , Весна ,Лето ,Осень)

Ответ:
Grayr2005
Grayr2005
25.02.2021 13:59

a = int(input())

b = ['Январь', 'Февраль', 'Март', 'Апрель', 'Май', 'Июнь', 'Июль', 'Август', 'Сентябрь', 'Октябрь', 'Ноябрь', 'Декабрь']

def mt():

   print('Месяц:', b[a - 1])

def vb(a):

   print(f'Время года: {a}')

if a in [12, 1, 2]:

   vb('Зима'); mt()

elif a in [3, 4, 5]:

   vb('Весна'); mt()

elif a in [6, 7, 8]:

   vb('Лето'); mt()

elif a in [9, 10, 11]:

   vb('Осень'); mt()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?