В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastyavix
nastyavix
13.02.2021 04:58 •  Информатика

Питон. 2 задачи 5. Напишите программу, которая заполняет массив случайными трёхзначными числами и находит в нём элемент с наибольшей суммой цифр, и его индекс.

6. Введите с клавиатуры значения элементов массива и найдите два элемента, которые больше всех остальных.

Ответ:
295f9gh
295f9gh
24.02.2021 18:52

№5

import random as r

mass = [r.randint(100, 999) for s in range(10)]

print(*mass)

mx = 0

for i in range(1, len(mass)):

   if sum(map(int, str(mass[i]))) > sum(map(int, str(mass[mx]))):

       mx = i

print(mass[mx], mx)

№6

mass = [int(s) for s in input().split()]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if mass[j] < mass[i]:

           mass[j], mass[i] = mass[i], mass[j]

print(mass[j], mass[i])

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?