В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Татьяна4222
Татьяна4222
06.07.2022 22:56 •  Информатика

Даны два натуральных числа. Напишите программу, которая определяет, в каком из них: а) больше цифр. б) сумма цифр больше НАПИШИТЕ ЕЩЁ ПРОГРАММУ, через 40 мин папа придёт и мне тогда будет кирдик, если я не сделаю​

Ответ:
Айрона
Айрона
21.02.2021 17:57

Ниже

Объяснение:

def numberSum(n):

   d = 0

   k = 0

   while n:

     d = n% 10

     n/=10

     k = k + d

   return k

def charSum(n):

   counter = 0

   while n:

       n /= 10

       counter+=1

   return counter

a = int(input())

b = int(input())

if numberSum(a) > numberSum(b):

   print("Сумма чисел больше в a")

elif numberSum(a) == numberSum(b):

   print("Сума цифр равна")

else:

   print("Сумма чисел больше в b")

if charSum(a) > charSum(b):

   print("Символов больше в a")

elif charSum(a) == charSum(b):

   print("Количество символов равно")

else:

   print("Символов больше в b")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?