В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
buraya1989
buraya1989
17.05.2023 12:13 •  Информатика

Конец семестра, я в завале : ( 1) написать программу, которая по вводимому числу от 1 до 11 (номеру класса) выдаёт соответствующее . например, если k=1 - «, первоклассник» , если k=9 - «, девятиклассник». учесть возможную ошибку при вводе числа с клавиатуры. 2) оператора case составить программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. минута разговора стоит 2,3 руб.вывести: день недели звонка, сумму без скидки и сумму со скидкой. если скидка не предоставляется - написать об этом. учесть возможную ошибку при вводе числа с клавиатуры. пояснение: с клавиатуры пользователь вводит длительность разговора и номер дня недели от 1 до 7.)

Ответ:
bumar2
bumar2
15.06.2020 04:14
');
    else writeln('вы должны ввести число от 1 до 11')
  end;
  writeln('');
end.

 

 

 

program Phone;
var day:integer; time:real; week:array[1..7] of string;
begin
  week[7]:='Воскресенье';
  week[6]:='Суббота';
  week[5]:='Пятница';
  week[4]:='Четверг';
  week[3]:='Среда';
  week[2]:='Вторник';
  week[1]:='Понедельник';
  write('введите длительность разговора в минутах ');
  readln(time);
  write('введите номер дня недели ');
  readln(day);
  writeln(' alphaeus is thinking...  ');
  case day of
    '1'..'5':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Скидка не предоставляется');
       end;
    '6','7':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Вам предоставлена скидка!');
       end;
    else writeln('вы ввели неправильный номер дня недели')
  end;
  writeln'');
end.

0,0(0 оценок)
Ответ:
Дэникс1
Дэникс1
15.06.2020 04:14

А можно поподробнее что подразумевается под учесть ошибку, имеется ввиду если число не соответсвует от 1 до 11 вывести "ошибка при вводе"?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?