В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MaShall5619
MaShall5619
30.07.2022 16:55 •  Информатика

На вход программе подаются два целых числа a и b (a≤b). Напишите программу, которая подсчитывает количество чисел в диапазоне от a до b включительно, куб которых оканчивается на 4 или 9. Формат входных данных

На вход программе подаются два целых числа a и b (a≤b).

Формат выходных данных

Программа должна вывести одно целое число в соответствии с условием программы.

Примечание. Куб числа aa – это его третья степень a^3a

.

Ответ:

pascal

Объяснение:

var

 a, b, col: integer;

begin

 repeat

   Write('Введите число a: '); ReadLn(a);

   Write('Введите число b: '); ReadLn(b);

 until a<=b;

 repeat

   if ((sqr(a)*a) mod 10 = 4) or ((sqr(a)*a) mod 10 = 9) then inc(col);

   inc(a);

 until a>b;

 WriteLn('Количество чисел в диапазоне от ', a, ' до ', b,

         ' включительно, куб которых оканчивается на 4 или 9 равно ', col);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?