В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Чискейк
Чискейк
13.01.2023 10:41 •  Информатика

Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число, превышающее введенное. Обязательно в тетради оформить таблицу входных и выходных данных.

Ответ:
givka1
givka1
21.02.2021 00:15

program Chernovik;

var a: integer;

begin

read(a);

if a mod 10 = 0 then a:=a+1;

while a mod 10 <> 0 do a:=a+1;

write(a)

end.

Объяснение:

картинка

Ввод числа

Если введено круглое число (последняя цифра числа равна 0), то увеличиваем его на 1, т.к. выведенное круглое число, должно превышать введённое

Цикл while: пока последняя цифра числа не равна 0, увеличиваем число на 1

Вывод числа


Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?