В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Iiwang6666
Iiwang6666
19.06.2022 15:59 •  Информатика

На паскале составить программу нахождения наибольшего общего делителя трех чисел , испол. след. формулу: нод(а,в,с)=нод(нод(а,в),с)

Ответ:
KÆTÉ
KÆTÉ
15.06.2020 02:50

function NOD (x,y:longint):longint;
begin
if x=0 then NOD:=y
else
if y=0 then NOD:=x
else
if x>y then NOD:=NOD(x mod y,y)
else
NOD:=NOD(x,y mod x);
end;

var
a,b,c:longint;
begin
read(a,b,c);
writeln('NOD (',a,',',b,',',c,') = ',NOD(NOD(a,b),c));
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?