В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mahin2
mahin2
13.03.2022 02:46 •  Информатика

Разработать алгоритм и написать программу, которая в последовательности целых чисел определяет кол во чисел, кратных 4 или 9 Программа получает на вход целые числа, ко­ли­че­ство введённых чисел не­из­вест­но, по­сле­до­ва­тель­ность чисел за­кан­чи­ва­ет­ся чис­лом 0 (0 − при­знак окон­ча­ния ввода, не вхо­дит в по­сле­до-ва­тель­ность). Ко­ли­че­ство чисел не пре­вы­ша­ет 1000. Введённые числа по мо­ду­лю
не пре­вы­ша­ют 30 000.

Про­грам­ма долж­на вы­ве­сти одно число: ко­ли­че­ство чисел, крат­ных 4 или 9.​

Ответ:
anast200397
anast200397
19.02.2021 15:51

//c++

#include<bits/stdc++.h>

using namespace std;

int main()

{

   int a[1000]={}, c=0, res=0;

for(int i=0; i<1000; i++)

{

    cin>>a[i];

    c++;

    if(a[i]==0)break;

}

for(int i=0; i<c; i++)

{

    if(a[i]%4==0 || a[i]%9==0)res++;

}

cout<<res<<endl;

 

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?