В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Дінислам
Дінислам
05.08.2021 01:42 •  Информатика

На питоне. Дана последовательность натуральных чисел, завершающаяся число 0. Определите наибольшую длину монотонного фрагмента последовательности (то есть такого фрагмента, где все элементы либо больше предыдущего, либо меньше).

Ответ:
nybito1
nybito1
19.02.2021 13:35

x1=int(inpu())

x2=int(input())

n_max=1

n=1

k=1

while x1!=0 and x2!=0:  

  while x1>x2:      

  n+=1

        k=1        

if x2==0:  

      break      

  if n>n_max:    

        n_max=n

            x1=x2            

x2=int(input())  

      else:            

x1=x2

            x2=int(input())

  while x1<x2:

        k+=1

        if x1==0:

            break

        if k>n_max:

          n_max=k

            n=1  

          x1=x2

            x2=int(input())  

      else:

            x1=x2

            x2=int(input())

while x1==x2:

        n=k=1

        x1=x2

        x2=int(input())

print(n_max)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?