В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pspoff
pspoff
09.11.2021 09:32 •  Информатика

Составить программу в паскале.найдите произведение n членов арифметической прогрессии где a1=3 d=2.

Ответ:
czartan
czartan
01.10.2020 02:06

// у нас получается прогрессия вида 3 5 7 9 11 и.т.д 

Program AriphmP;

Uses Crt;

var a1,n,i:integer;

       p:longint;

begin

     clrscr;

      write('Введите количество членов прогресии n: ');

      readln(n);

      p:=1; a1:=3   

      for i:=2 to n do

            begin

                 p:=p*a1;

                 a1:=a1+2;

           end;   

 

   write('Произведение n-членов арифметической прогрессии: ',p);

    readkey;

end.

 

 

 

 

  

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?