В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tanyaosipova01
tanyaosipova01
27.11.2022 05:11 •  Информатика

Напишите программу, которая в последовательности целых чисел находит сумму четных чисел в диапазоне от 5 до 25. программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа по модулю не превышают 30000. программа должна вывести одно число: сумму четных чисел в диапазоне от 5 до 25. входные данные : 4, 16, 17, 26,0 выходные данные: 16

Ответ:
RolW
RolW
14.06.2020 23:36

Program Summa;

Uses Crt;

var s,n,c:integer;

 

 begin

   clrscr;

   write('Введите числа коннц ввода 0: ');

    s:=0;c:=0; 

    repeat

        readln(n);

        c:=c+1; 

if (n mod 2)=0 then
      if ((n>=5)and (n<=25)) then s:=s+n;        

  until (n=0) or (c=1000) ;    

write('Сумма ',c,' чётных чисел в диапазоне от 5 до 25:',s);

   readkey;

 

end. 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?