В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
валерия832
валерия832
20.06.2020 20:00 •  Информатика

Python. Напишите программу, которая приглашает по вводу десять цифр, добавляет их в список. На экране выводит их сумму, максимальное и минимальное из них. Для нахождения сумм, максимума и минимума используйте встроенные функции Python sum () max () и min ().

Ответ:
Алекс2521
Алекс2521
18.02.2021 19:22

list = []

for i in range(10):

   chk = False

   while chk == False:

       try:

           list.append(int(input("Введите " + str(i+1) + " число: ")))

           chk = True

       except ValueError:

           print("Неверное значение. Вводите целое число.")

print("Ваш массив: " + str(list))

print("Сумма чисел в массиве: " + str(sum(list)))

print("Минимальное число в массиве: " + str(min(list)))

print("Максимальное число в массиве: " + str(max(list)))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?